Enclaveforum.net
Bookmark and Share
April 27, 2017, 04:58:38 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Forum Tip: See that little gray camera icon in a member's post? Click it to go directly to their Photo Gallery
   
   Home   Help Search Gallery Login Register  
Registered users see fewer ads.
Pages: [1]   Go Down
  Print  
Author Topic: 2009 Buick Enclave Navigation Dvd Error  (Read 313 times, 3 Replies)
1BigRed1
Newbie
*
Offline Offline

Posts: 1
Joined: Apr 2017




Ignore
« on: April 15, 2017, 06:58:55 PM »

    We have a 2009 Buick Enclave, When we click on destination, were getting a Navigation DVD Error It has about 107,000 miles on the car. I hope someone can help.
« Last Edit: April 15, 2017, 07:57:51 PM by 1BigRed1 » Logged
Fcar53
Jr. Member
**
Offline Offline

Posts: 76
Location: Pittsburgh Pa
Joined: May 2016




Ignore
« Reply #1 on: April 15, 2017, 09:07:52 PM »

My 2009 Traverse LTZ had the same problem. Needed to replace the nav unit. Laser reader is going bad.
Logged

1998 torch red corvette                                                                                      2011 silver ice equinox LTZ                                                                                 2015 white diamond enclave premium
BadAV
Enclave Freak
******
Offline Offline

Posts: 1685
Location: O'Fallon, MO
Joined: Sep 2007





Ignore
« Reply #2 on: April 18, 2017, 08:52:50 AM »

Yep, to the tune of $1200 "at cost" according to our dealership when ours went out. I told them I would buy a top of the line aftermarket unit if I was inclined to spend that kind of money. Needless to say we lived without the sh!tty OEM nav unit. A cheap Garmin nav or your cell phone work much better anyway.
Logged

Wife's: 2014 TorRed Dodge Charger SXT Plus, replaced 2008 Enclave CXL

Newest toy: 2015 F150 Lariat Supercrew FX4 3.5 Ecoboost

Daily driver: 2012 4LT Grand Sport Corvette Centennial edition convertible
Uncle Buick
Jr. Member
**
Offline Offline

Posts: 94
Location: Toronto, Ontario
Joined: Aug 2015




Ignore
« Reply #3 on: April 19, 2017, 07:56:55 PM »

My Nav stopped working for about 6 months.  Kept getting a "map disc error" message, and the NAV button was greyed out and would not allow you to select it. I added to another navigation post about 6 months ago looking for assistance on what might be the problem... and others chimed in along the same lines that the nav unit needed to be replaced....  one of the posts said to try and use compressed air in a can, and blow into the nav slot, which didn't work for me.

Low and behold about a month ago, the nav has started working again?!  and its working great again...  Has been working for about a month or more now... works every time on the first try... I have NO idea what changed.
Logged

2011 Cocoa Metallic w/Tan Interior CXL2 AWD
Pages: [1]   Go Up   [ Home | Unread Posts | Unread Replies ]
  Print  
 
Jump to:  
Custom Auto Accessories

Powered by MySQL Powered by PHP Powered by SMF 1.1.15 | SMF © 2011, Simple Machines | Sitemap
SMFAds for Free Forums
©2017 enclaveforum.net All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
Valid XHTML 1.0! Valid CSS!