Air Conditioning Not Working - New Temp Control Switch - EnclaveForum.net: Buick Enclave Online Community
Reply
 
LinkBack Thread Tools
post #1 of 21 (permalink) Old 05-02-2016, 03:16 PM Thread Starter
Jr. Member
 
Join Date: Dec 2015
Posts: 14
Air Conditioning Not Working - New Temp Control Switch

Hi Guys -

I recently installed a used temperature control module because the old ones buttons were peeling pretty bad. I tried turning on the AC and when I push the ac button it flashed a couple times then just goes way. The ac seats seem to work just fine. just no blowing cold air. AC worked before I switched them. Any idea?? Thank you!
lenoble22 is offline  
post #2 of 21 (permalink) Old 05-02-2016, 03:57 PM
Enclave GOD!
 
Join Date: Sep 2009
Posts: 6,419
Re: Air Conditioning Not Working - New Temp Control Switch

what happens when you put the original panel back in?

2010 FWD LT1-Gold Mist Metallic- seats 8
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L 83,000
2010 Traverse 3.6L 148,000
2003 Trailblazer 4.2L 181,500
rbarrios is offline  
post #3 of 21 (permalink) Old 05-02-2016, 09:07 PM
Enclave GOD!
 
cfedor's Avatar
 
Join Date: Oct 2012
Location: The Racing Capitol of the World
Posts: 5,881
Garage
Re: Air Conditioning Not Working - New Temp Control Switch

Quote:
Originally Posted by rbarrios
what happens when you put the original panel back in?
It is a same model year to same model year swap out? i.e. 2008-12 or 2013-15?

HIS: 2008 Enclave CXL AWD Red Jewel/Titanium Leather, Premium package 19" Chrome 7-spoke, AM/FM/CD/DVD/NAV 10 speaker Bose, LED upgrades inside and out, 156K Miles

HERS: 2009 Toyota Sienna XLE AWD Black/Tan Loaded. 132K Miles
cfedor is offline  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 05-02-2016, 10:03 PM
Enclave Freak
 
Join Date: Dec 2008
Posts: 1,478
Re: Air Conditioning Not Working - New Temp Control Switch

Good suggestion by rbarrios to swap the parts again and see if the old one is working. The used one you installed may be bad.

You may also have to reset the controls by unplugging the fuse. Search the board for resetting the HVAC system. I'd try that first just to make sure it isn't something that simple.

2010 Summit White Traverse LTZ,&nbsp; SOLD 4/2012&nbsp; <br />2015 Traverse 2LT Siren Red Tintcoat-36 Month Lease
ls973800 is offline  
post #5 of 21 (permalink) Old 05-08-2016, 05:38 PM Thread Starter
Jr. Member
 
Join Date: Dec 2015
Posts: 14
Re: Air Conditioning Not Working - New Temp Control Switch

I tried swapping the old one and same thing......no different

Yes swapped a 12 control unit into a 10, same part number.

I will try to find a way to reset the HVAC system, I will search unless someone has a link.

Thanks.
lenoble22 is offline  
post #6 of 21 (permalink) Old 05-09-2016, 12:36 AM
Hero Member
 
Join Date: Sep 2008
Posts: 733
Send a message via AIM to rexster Send a message via MSN to rexster Send a message via Yahoo to rexster
Re: Air Conditioning Not Working - New Temp Control Switch

Which control does yours look like?
Attached Images
File Type: jpg control 2015.jpg (65.3 KB, 6 views)
File Type: jpg control 2010.jpg (89.0 KB, 9 views)

Rex<br />09 Red Jewel CXL Enclave Traded for KR Ford Expedition May 27, 2012<br />My other car is 2006 Cadillac XLR
rexster is offline  
post #7 of 21 (permalink) Old 05-09-2016, 02:56 PM Thread Starter
Jr. Member
 
Join Date: Dec 2015
Posts: 14
Re: Air Conditioning Not Working - New Temp Control Switch

It looks like the bottom one, from 2010
lenoble22 is offline  
post #8 of 21 (permalink) Old 05-09-2016, 05:25 PM
Hero Member
 
Join Date: Sep 2008
Posts: 733
Send a message via AIM to rexster Send a message via MSN to rexster Send a message via Yahoo to rexster
Re: Air Conditioning Not Working - New Temp Control Switch

http://www.ebay.com/itm/2007-2009-BU...hWZ8g6&vxp=mtr

Rex<br />09 Red Jewel CXL Enclave Traded for KR Ford Expedition May 27, 2012<br />My other car is 2006 Cadillac XLR
rexster is offline  
post #9 of 21 (permalink) Old 05-09-2016, 05:38 PM Thread Starter
Jr. Member
 
Join Date: Dec 2015
Posts: 14
Re: Air Conditioning Not Working - New Temp Control Switch

Thanks for the link to the stickers but that does not fix my problem. I tried swapping in the old one HVAC module and still not any better (they are the exact part number). Tried to reset the module by removing the fuse and disconnecting the battery......still not any better. I talked to a buddy who works for GM and he said if it is flashing, then it is out of freon. He said that the cooled seats are not connected to the ac compressor and that it is only a fan that blows air through the seats. Going to see if adding freon works. thanks.
lenoble22 is offline  
post #10 of 21 (permalink) Old 05-10-2016, 12:38 AM
Hero Member
 
Join Date: Sep 2008
Posts: 733
Send a message via AIM to rexster Send a message via MSN to rexster Send a message via Yahoo to rexster
Re: Air Conditioning Not Working - New Temp Control Switch

SO: Everything was working, A/C and heat, as normal when you removed the original control panel. You changed out the control, tried to get A/C to work and now nothing works? Does heater work? Defroster? Rear air won't work if compressor won't turn on. I don't think the control needs to be flashed. Try starting car, then run the temp setting all the way to high, then all the way cold. If everything was working before switching out the control, then the second control is faulty and may have futzed up something in the system.

Rex<br />09 Red Jewel CXL Enclave Traded for KR Ford Expedition May 27, 2012<br />My other car is 2006 Cadillac XLR
rexster is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the EnclaveForum.net: Buick Enclave Online Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome