outside temp display stuck at erroneous value - EnclaveForum.net: Buick Enclave Online Community
Reply
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 07-29-2011, 12:32 PM Thread Starter
Hero Member
 
Join Date: Sep 2007
Posts: 661
outside temp display stuck at erroneous value

I have had no problems with my 08, save the nav which was FINALLY made right by replacement of whole unit.
The other day, hot summer day, the outside temp display said 66. it stayed there for about three days regardless of actual temp. Then, it started working normal (although I suspect it is not as accurate as it was).
I have an oil change scheduled for Monday and asked service writer to look at this problem.
Question is: Has anyone seen a similiar problem?

11 Ming Blue AWD CXL1 Owned 22 months 10,000 miles.
REDCXL is offline  
post #2 of 12 (permalink) Old 07-29-2011, 12:37 PM
Enclave GOD!
 
Join Date: Sep 2009
Posts: 6,411
Re: outside temp display stuck at erroneous value

next time it does this.
Hold down the AC and recirculate button to get the computer to do an instant reading. the reading should change immidiately.
(this works on the manual AC systems)

2010 FWD LT1-Gold Mist Metallic- seats 8
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L 83,000
2010 Traverse 3.6L 148,000
2003 Trailblazer 4.2L 181,500
rbarrios is offline  
post #3 of 12 (permalink) Old 07-29-2011, 03:51 PM
Enclave Freak
 
Join Date: Jun 2007
Posts: 1,339
Re: outside temp display stuck at erroneous value

You may need to drive it forabout 10 minutes over 40 mph... Pretty common issue with Enclaves. I have a 2010 and the temp reading gets stuck all the time unless I take it on a highway.

2010 CXL-1 FWD, towing, sunroofs - a different fruit - also gone <br /><br />2008 CXL FWD, towing, confidence, sunroofs - LEMON - gone
chumster is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 07-29-2011, 04:27 PM
Enclave GOD!
 
Join Date: Sep 2009
Posts: 6,411
Re: outside temp display stuck at erroneous value

there is an algorithm that this thing uses to update temp.
one of them is to not update temp if car is moving slowly (so as not to measure the engine temp )-- or it cars been sitting for a short period of time-- it compares values etc.. Ive posted it before.

But you say 3 days.... hmmmm

2010 FWD LT1-Gold Mist Metallic- seats 8
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L 83,000
2010 Traverse 3.6L 148,000
2003 Trailblazer 4.2L 181,500
rbarrios is offline  
post #5 of 12 (permalink) Old 07-29-2011, 06:36 PM
Enclave Guru
 
rockyp's Avatar
 
Join Date: Jan 2008
Posts: 2,851
Re: outside temp display stuck at erroneous value

Quote:
Originally Posted by rbarrios
next time it does this.
Hold down the AC and recirculate button to get the computer to do an instant reading. the reading should change immidiately.
(this works on the manual AC systems)
Interesting tip! Have any others? Any Easter Eggs in the nav or anything?

2008 Cocoa CXL AWD, Nav, Rear Ent - Owned 72 months, 135,900 miles. Traded 9 days short of 6 years of ownership for new Subaru Outback.<br /><br />If God wanted me to touch my toes, He would've put them on my knees.
rockyp is offline  
post #6 of 12 (permalink) Old 07-29-2011, 07:39 PM Thread Starter
Hero Member
 
Join Date: Sep 2007
Posts: 661
Re: outside temp display stuck at erroneous value

Quote:
Originally Posted by rbarrios
there is an algorithm that this thing uses to update temp.
one of them is to not update temp if car is moving slowly (so as not to measure the engine temp )-- or it cars been sitting for a short period of time-- it compares values etc.. Ive posted it before.

But you say 3 days.... hmmmm
Yes, and in that time the car sat for periods of 3+ hours in the sun on a 95+ plus day. In the past when that happened the temp would read 100+ until i drove it a ways. These three days also included at least 6 times on the freeway with speeds of 60+/-.
I have a background in electronic maintenance and repair and I hate intermittent problems. I know if they are reported by a non-tech operator, we frequently role our eyes and say. suuuuuuuuuuuure!
Thanks for the ideas, I will try the "tricks."

11 Ming Blue AWD CXL1 Owned 22 months 10,000 miles.
REDCXL is offline  
post #7 of 12 (permalink) Old 07-29-2011, 11:20 PM
Enclave Freak
 
Join Date: Dec 2008
Posts: 1,478
Re: outside temp display stuck at erroneous value

Not too uncommon for the sensor which is located under the hood in the radiator area to go bad. I believe they really just give an electrical value (Ohms) which is read and translated into a digital reading of the temperature.

2010 Summit White Traverse LTZ,&nbsp; SOLD 4/2012&nbsp; <br />2015 Traverse 2LT Siren Red Tintcoat-36 Month Lease
ls973800 is offline  
post #8 of 12 (permalink) Old 08-01-2011, 03:42 PM
RCH
Sr. Member
 
Join Date: Sep 2008
Posts: 469
Re: outside temp display stuck at erroneous value

Quote:
Originally Posted by rbarrios
next time it does this.
Hold down the AC and recirculate button to get the computer to do an instant reading. the reading should change immidiately.
(this works on the manual AC systems)
This works for the Auto type AC systems also. I did it this past weekend while waiting for the wife at shopping center. It went from 94 to 100 since I was sitting still. In a couple of minutes it was 95, when pushed again, it went to 99 and slowly started going back down again.

RCH

2009 CXL AWD Enclave Carbon Black Metallic / Ebony Interior: Navigation Entertainment #4, Sunroof, 2nd Row Console, Heated and Cooled Seats, Driver Confidence Package, Luxury Package, Trailer Package, 19" Chromes, drove from Indy to St. Louis to get.
RCH is offline  
post #9 of 12 (permalink) Old 08-02-2011, 01:14 AM Thread Starter
Hero Member
 
Join Date: Sep 2007
Posts: 661
Re: outside temp display stuck at erroneous value

Orinator of this thread. dealer checked it out today and was unable to fix it. I assume they checked the sensor first, but service writier came to me after a loong time and said they were working with software, and unalbe to fix the probem. Suggested I caome back another day. (I had other commitments.)
So still no joy.

11 Ming Blue AWD CXL1 Owned 22 months 10,000 miles.
REDCXL is offline  
post #10 of 12 (permalink) Old 11-24-2012, 09:19 PM
Jr. Member
 
Join Date: Nov 2012
Posts: 32
Re: outside temp display stuck at erroneous value

Mine did it also. I relaced the sensor for 7 bucks at the dealer and works fine.

2008 Buick Enclave CXL, 58K<br />2004 Dodge 3500 DRW 5.7 HO with Superchip, K&N, 128K<br />1989 Yamaha Venture Royal, 114K
Billd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the EnclaveForum.net: Buick Enclave Online Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome