EnclaveForum.net: Buick Enclave Online Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We have been having issues with our enclave shutting off while driving with no warning. Most of the time it will start back up when turned off and restarted but sometimes it will take 20 minutes to restart up to hours before restarting. We have replaced the relay starter and purge valve and worked great for a while then started doing same thing again... shutting off randomly with no warning. Anyone have similar problems or know of this issue? Just had it at the mechanics for two weeks and was told they cannot figure it out and had the battery charged up and working fine for him but the first time we take it out to the store it does it again right away!
 

·
Registered
2015 Enclave Leather.
Joined
·
713 Posts
First thing to check is the engine compartment fuse block. There are two bolts which hold the upper and lower sections which may be loose. If possible take the sections apart, check pins making sure they are aligned properly and re-seat the sections. Tighten the bolts snug, not over tight.
 

·
Registered
Joined
·
73 Posts
Has anyone checked for fault codes? A vehicle can shut off or stall for a LOT of reasons. The whole purpose of having the ability to check fault codes is to inform the driver of an issue and provide some guidance to where the problem may lye. As electbc said, it may lye with the fuse box, in which case there should be "Lost Comms" codes with the engine ECU/ECM. Good luck.
 
1 - 3 of 3 Posts
Top