EnclaveForum.net: Buick Enclave Online Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1 (Edited)
Liftgate has been flaky for years, but it's always worked from the fob and also the rocker switch on the dash was fine so we never really pursued it. Manual close, no big deal.

After I closed it ("roughly" according to my wife) we're seeing the "liftgate open" message on the DIC. It's shut tight. I opened it through the release hole on the inside and took off the panel to see if I can find anything. Was hoping to see a sensor that was broken but no luck. According to the parts catalog there is an "ajar sensor" but I can't seem to find it. I just see the close and open buttons and the actuator.

I'm going to buy the close/open buttons since I know they're bad. I disconnected them and "liftgate open" is still on the DIC, so probably not the cause.

Does is sound like an actuator issue? I understand there is a control module by the motor as well. Is there an ajar sensor somewhere?

I'm fine with not having a powered liftgate but I need it to open/close manually and get rid of the message on the DIC. Don't want to spend $700+ at the dealer for this.

Original owners since 2008 and otherwise she's holding up.

Thanks.


Quick edit: The lights do blink when I click the fob so it's at least getting a signal to open (but it thinks it already is open). I don't hear any gears or movement then.
 

·
Registered
Joined
·
5,910 Posts
I thought that the two rubber mouldings on the left and right were sensors or mag switches for the liftgate door being open or closed.
 

·
Registered
Joined
·
352 Posts
I thought that it was actually part of the latch mechanism. Looks like it is, according to the wiring diagram, I tried to post it but no luck so far.

file:///C:/Users/bcele/AppData/Local/Temp/Temp1_Enclave08-10.zip/Buick%20Enclave%2008-10%20Factory%20Service%20Repair%20Manual/2009-2010%20-%20Service%20Manual/Schematic%20and%20routing%20Diagrams/Door%20LockIndicator%20Schematics%20(AXC%20or%20AXE).pdf
 

·
Registered
Joined
·
352 Posts
I thought that the two rubber mouldings on the left and right were sensors or mag switches for the liftgate door being open or closed.
The left and right sensors are the object sensors, the latch has the ajar sensor in the assembly although is is hard to see it in the diagram I have, even a GMParts now diagram is very vague.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Update: Good news, I think. I disconnected the battery for a few minutes and it's no longer reporting "liftgate open". Upon reconnect, the latch mechanism was having a hard time closing tight but it eventually did. I have new buttons and the ajar sensor on order, will replace those this week and report back.
 

·
Registered
Joined
·
352 Posts
If your latch is having issues completely closing and latching, you may have an obstruction in the gate, the molding, or the rubber bumpers. or maybe it just needs a shot of lithium grease in the latch mechanism.
 
1 - 7 of 7 Posts
Top