EnclaveForum.net: Buick Enclave Online Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
The other day my power steering is acting up. It's sometimes really hard to turn especially when I'm not moving? I'm not sure if it's my rack or my pump or both?? I'm also getting mixed information stating that adding transmission fluid and not power steering fluid and vice-versa. Also how do you tell if I have a variable power steering nv7 . Tia
 

·
Registered
Joined
·
7,008 Posts
Have you checked the serpentine belt? May be slipping.... could be old and not gripping under load.
Does the rpo tag have the code for variable ps?
Theres also a sensor attached to the rack on variable units.

2012s i believe is when GM switched over to dexron vi trans fluid for ps.
Before that it used regular clear ps fluid. Over time it turns black.
 

·
Registered
Joined
·
7,008 Posts
Your ps cap area may have a label indicating dex vi required.
Do not add reg fluid...
Something to do with the rubber seals not liking reg ps fluid.
 

·
Registered
Joined
·
1 Posts
The other day my power steering is acting up. It's sometimes really hard to turn especially when I'm not moving? I'm not sure if it's my rack or my pump or both?? I'm also getting mixed information stating that adding transmission fluid and not power steering fluid and vice-versa. Also how do you tell if I have a variable power steering nv7 . Tia
I think they started the TF in 2012. I have a 2011 Acadia Denali that takes TF. The person I bought it from or his mechanic used a paint pen on the cap. Im guessing things were replaced and updated. I have issues here and there at slow speeds the wheel gets tight but is only here and there.
 
1 - 5 of 5 Posts
Top