EnclaveForum.net: Buick Enclave Online Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Had battery replaced, now auto temp does not work. Took to dealer. Said air actuators not working. Need to replace all three for $1800!!!! See on Google a common problem with Chevy's. HELP
 

·
Registered
Joined
·
6,623 Posts

·
Registered
Joined
·
6,623 Posts
also- you may want to reset the HVAC- to relearn their home positions.
read the entire thread-- maybe someone has had your issue and posted a fix,
 

·
Registered
Joined
·
136 Posts
Rbarrios is correct. I replaced 2 of mine. A bit tough to get in there. A mini ratchet came in handy. My dealer couldn’t figure why driver side wasn’t blowing as cold as passenger side with AC on. Went back twice and I asked about the actuators. He said he tested driver side and was good. I took a 30 dollar gamble and did it myself. Problem solved. I think half these techs are not reliable, at least at the dealer I went to. They charged me 800 dollars to change condenser thinking that as problem. It didn’t solve it. I solved it by replacing 30 dollar part they wanted another 200+ dollars to replace. Can’t make this stuff up!
 

·
Registered
Joined
·
2 Posts
I did two. One was fried on the inside. Did you smell electric burning. I did in mine. Be aware you may need another elbow.lol
 

·
Registered
Joined
·
9 Posts
Hi,

I had a really similar problem on my 2011 when the battery died. After jumping it the HVAC would not work right. It would only blow hot sometimes, others only at your feet. Weird things like that.

Solution: disconnect the battery again!

You may also need to pull the relevant fuse for a few minutes. I think it's in the passenger footwell. There's a fuse puller in the middle of the main fuse box under the hood. Knowing that would have saved me a couple trips to the parts store.

It's worth trying before shelling out for replacing the actuators.
 
1 - 7 of 7 Posts
Top