EnclaveForum.net: Buick Enclave Online Community banner
1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
My 2018 Enclave has a power button on the door which folds both the driver and passenger side mirrors (this is not the mirror positioning controls).

I had an accident and the driver side mirror was damaged. After replacement by the collision shop (dealer), I noticed the driver side mirror didn't fold (the passenger side does).

When I mentioned this to the dealer, they said they didn't realize the 2018 Enclave had this feature. Now, they can't find one (still searching). Does anyone know how to get the
part number or where I might get a replacement? It doesn't have to be new.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
They have all the information and are the ones who can't find a new or used one so far. I found one on e-bay and asked if it was one which would work as I described but they never responded. I haven't had time to pursue it further and thought I'd ask here so I can do my own research.GM isn't doing anyone any favors since there are other parts which the dealer had to search a long time to find. We're talking months.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
I called the dealer this morning to pass on where they could get the mirror and, they had already found one. It was delivered this morning.

Thanks for your help on this.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Interesting. After the dealer painted the mirror they had found, they called me and said it was the part specified by the insurance company and it was the wrong part so they didn't install it. They were looking for another one with the correct part number. I looked at the list of replacement parts the insurance company sent me before the repairs were made and, sure enough, they specified a mirror without the power fold. I went down to the dealer with a screenshot of the list from GMPartsDirect, which is a new part with a different part number. The dealer informed me that they couldn't use it because the insurance company had specified a used part. I said, you mean I've been waiting five months because the insurance company specified a used part. They said yes and that they had talked to the insurance company to no avail. I then called the insurance company agent and she said this was the first she had heard about it and said that the parts were specified by the appraiser. She then sent an e-mail to the appraiser to get this straightened out. I haven't had time to talk to the dealer to see if the problem has been resolved. Will report back.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #9 ·
Not State Farm. The company has been great in taking care of me. I don't know who the dealer was talking with at the insurance company but it wasn't the agent.
 
1 - 10 of 10 Posts
Top