EnclaveForum.net: Buick Enclave Online Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all. I'm not sure if this is the right forum but I hope someone can direct me to the proper place for help on this issue.
We have a 2009 cxl with 150K + Miles on it. The car was originally from AZ but we live in Wisconsin. We put the car in storage in the house garage last October and when we Started it last month the "Service Air Bag" message shows up every time you start it. I got ahold of a DTC scanner and it says that both my front impact sensors are either shorted or open. (B0083-05 and B0084-05) I find it highly unlikely that both sensors went bad at the same time. The schematic shows that there is a connection somewhere into the main harness but I cant tel where.
I'm thinking that it may be a bad connection caused by sitting in the cold damp environment. (I had a similar issue with the parking brake and some engine errors)
Has anyone had this problem and fixed it? Or, does anyone know where the two front end sensor wires plug into the main harness?
Any help would be greatly appreciated!
 

·
Registered
Joined
·
1 Posts
My first thought is mice damage with it being in storage for a long period somewhere cold.
Yep, you are right. There is an 8 pin connector on the passenger side on the outside of the fuse box under the top of the fender. 4 of the wires were severed. I had to resolder them and that took care of the message
6426
 

·
Registered
Joined
·
378 Posts
When you store your vehicles always leave hood open critters like a closed and secure place to make nests and chew on wiring. I f possible get a LED strobe light (Rid A Rat) is what i use and its been working great for 4 years.
 

·
Registered
Joined
·
375 Posts
Where is that? And does a 2008 have it also? I looked in mine but didn't see anything like that.

Yep, you are right. There is an 8 pin connector on the passenger side on the outside of the fuse box under the top of the fender. 4 of the wires were severed. I had to resolder them and that took care of the message View attachment 6426
 
1 - 6 of 6 Posts
Top