EnclaveForum.net: Buick Enclave Online Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I own a 2015 Buick Enclave and just recently the Service Air Bag will display as well as the red airbag light on the dash. Sometimes it goes off when I move the driver seat and other times it goes off while driving. I can’t find any information that there is a recall. If I take it to the dealership they will say it’s something major. Any others having the same issue?
 

·
Registered
Joined
·
511 Posts
There were problems in earlier models, my 2008 in fact, that the under seat airbag connector was defective. First recall was to re do the pins, the second was to eliminate the connector and solder the wires directly. I have not heard about any problems with the 2015, YET. I also have a 2015 now. The Airbag connector is Yellow. Check the connector, make sure that there is a locking string and the connector is intact Make sure there is no moisture down there, no chafing no strained wiring, and no foreign objects to interfere with the seat movement and wiring. Don't disconnect the connector.
I found 3 complaints on NHTSA site. Seems like Under Seat Connector. 2015 BUICK ENCLAVE SUV FWD
And more complaints for Traverse. 2015 CHEVROLET TRAVERSE SUV AWD
A few for Acadia, one complaint does mention it happens when the drivers seat is moved. 2015 GMC ACADIA SUV AWD
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
@electbc Thank you! I will check the yellow connector under the driver seat to see what I find. I have also noticed that when it's hot outside (Texas Weather) this occurs more than when it's cold. Somedays it doesn't even come on. I am just worried if they will deploy if ever in accident. I also read that I could disconnect the battery and it may reset it? Other than this issue I love the Enclave.
 

·
Registered
Joined
·
2 Posts
Mine is a 2012, and I have experienced the same thing with the Air Bag light coming on inter-mittingly. My first hunch was that there was a short, but then I thought it might be a loose plug. Had my wife monitor the dash lights while I got in the floor board and moved the connection. Sure nuff, that was where the problem was. Stableized the connection and had no problems since.
 

·
Registered
Joined
·
1 Posts
@electbc Thank you! I will check the yellow connector under the driver seat to see what I find. I have also noticed that when it's hot outside (Texas Weather) this occurs more than when it's cold. Somedays it doesn't even come on. I am just worried if they will deploy if ever in accident. I also read that I could disconnect the battery and it may reset it? Other than this issue I love the Enclave.
Mine is a 2012, and I have experienced the same thing with the Air Bag light coming on inter-mittingly. My first hunch was that there was a short, but then I thought it might be a loose plug. Had my wife monitor the dash lights while I got in the floor board and moved the connection. Sure nuff, that was where the problem was. Stableized the connection and had no problems since.
Are all the connections under the driver's seat?
 
1 - 7 of 7 Posts
Top