EnclaveForum.net: Buick Enclave Online Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
My 2009 Enclave CXL( only 110 000mls by now) is in Germany so it is more and more difficult to get things fixed. Now the ABS control light is always on and in the display it shows AWD off and serve stabilitrac. It has happened before but the station that does the repairs on my car was never able to find the problem. Maybe someone could give a hint what could be the reason. Even though the car is 13 years old now I still love driving it.
Rainbow Tire Wheel Cloud Vehicle
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #3 ·
Could be a number of things, plenty of previous posts on the subject on all of the Lambda Platform Forums. Easiest thing to check is Brake Fluid level. Also, do a scanner diagnosis on the ABS system. Could be a wheel sensor not functioning, possibly even debris in the reluctor.
Thanks a lot for the fast reply. I will mention all to the mechnics and as well check previous posts.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #5 ·
Post the error codes for a starter.
Thanks for Your attention to my post but unfortunately error codes are not available as the Enclave has never been sold officially in Germany. The mechanics don t have the specific software and it s not worth while for them to get those as there might be only a handful Enclave cars on the roads in Germany.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #8 ·
If you have a smartphone, you should be able to download the free app for this and purchase the Bluetooth interface.
BlueDriver
A lot of the times, there is no check engine light for these software generated messages so there isn't a code to read.
I know what you mean about loving to drive it, I had the Saturn Version, the Outlook a 2008 which I sold in 2018 with 212,000 miles on it, then I purchased a used 2015 Enclave leather. So far, no issues with it, now 103,000 miles.
I posted many time on this issue as I had those messages for some time before I had my mechanic spend a good part of the day troubleshooting. He did trace it to the Mass Air Flow sensor. Years later my daughter wanted to use the truck on a trip, she had the message, I looked at the brake fluid level, low, topped it off and away she went.
Thanks a lot for recommending the "Blue Driver". I was going to ask my mechanic station if they think it could help in future if I buy that, its rather affordable price. However it seems to be not available at the moment with amazon. My next appointment is in 2 weeks and I hope they find a way to deal with the problem. Car otherwise just drives fine just without ABS and Stabilitrac. But when I made my driver s license those things had not even been invented so I should be fine for now. Kind regards from Ennepetal-Germany
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #11 ·
Thanks for all the hints, the Bosch station now confirmed that one of the wheel speed sensors does not work. I was able to find the OEM part on amazon US and luckily they can ship within 10 days to Germany.
 
1 - 5 of 5 Posts
Top