EnclaveForum.net: Buick Enclave Online Community banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Mechanically everything’s been fixed according to my mechanic whom doesn’t do electrical jobs. He said he fixed everything mechanical but it’s now electrical.
rebuilt motor replaced timing chain
New crankshaft cam shaft sensors
Now it’s throwing these codes in the picture.
I did order a new ecm to be sure it wasn’t that.Should have it next week.
also anyone know anything about the positive terminal on the side of the fuse box? Mine broke off and it is plastiwelded back on but could that be the culprit to my electrical issue??
Font Technology Screenshot Electronic device Magenta
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I bought this truck used from a bug here pay here place long story short she ran like a champ then after only 2 -3 months of having her she broke down. I got the carfax and no flood damage and etc and I’m the third owner so I’m unsure of the stuff it went thru before me and when with me I took great care of it but since it’s broke down I haven’t been able to figure out how to get it working. A mechanic told me it needed new timing chain amd once he got the truck to the shop he told me it would be better to rebuild the motor so he did that but then told me it had electrical problems but he could t do that. So here I am and I did find some bare wires at the ignition coils so I put some electrical tape on them and now Ive just got one o2 /sensor wire connector replacement that’s wires don’t match the colored wire that goes to the harness the new connector wires are all white and the ones coming from harness are red black orange and one more color I’ll have to look them I was going to see what it does after I hook that up but I wonder if the computer is bad??
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Whats the history of the car?
Salvage?
Car accident, water damage?
Or yours but engine blew?
Bought at buy here pay here place no accidents no water and it just lost power and wouldn’t go and kept throwing codes so many different ones and one day the cat glew orange and then it wouldn’t drive after that but now I was able to rewrite an o2 sensor back the correct way and from there I cranked it up I’m posting a video I’m not sure what the noise is but this is where I’m at I’ve also checked all grounds with car crunk and just on acc. All is well. But that Tcm keeps whining and that I don’t get which I’m k mechanic just a single mom with some work ethic and no give up in my blood lol any advice or help is so much appreciated you have no idea!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
What year? I have some earlier model Lambda service info in the PDF links. Is does change some from year to year but this is all I have.
Since a lot was disturbed doing the engine work, make sure all the grounds are connected properly and check the engine compartment fuse block, it has a tendency to be loose, especially after repairs and not re connected properly. Then also check other connectors making sure they are tight and no bent pins. One of the wiring diagrams should show wiring to your O2 sensor. Use the search function on the PDF to find what you are looking for.

Adobe Acrobat

Adobe Acrobat

Adobe Acrobat

Adobe Acrobat
TJANK YOU SO MUCH I’m copying my reply to another person to let ya in on where I’m at so far ….

Bought at buy here pay here place no accidents no water and it just lost power and wouldn’t go and kept throwing codes so many different ones and one day the cat glew orange and then it wouldn’t drive after that but now I was able to rewrite an o2 sensor back the correct way and from there I cranked it up I’m posting a video I’m not sure what the noise is but this is where I’m at I’ve also checked all grounds with car crunk and just on acc. All is well. But that Tcm keeps whining and that I don’t get which I’m k mechanic just a single mom with some work ethic and no give up in my blood lol any advice or help is so much appreciated you have no idea
And how can I post videos to show the sound it making
 
1 - 4 of 4 Posts
Top