EnclaveForum.net: Buick Enclave Online Community banner
1 - 6 of 6 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My First Post!!!


I own a 2008 CXL. Currently the drivers door locks, mirrors, windows, memory seat do not work. I have already replaced the master switch. (Not the problem as they still do not work). Checked the main harness connection at the door for signs of moisture (Dry). When I open the door the lights do not come on, similarly when I shut the vehicle off and open the door the radio and lights should go out (they do not).


I do know that we have moisture water problems, however maintenance records show that the drain tube extension for the moon roof were already fixed previously. I did have the windshield replaced and contacted the company and had them check it out.


I have checked all the fuses. (Unless there are relays as well I have not checked them) Windows on all other doors work. Door lock button on passengers side door does not work as well. Could this be an addition issue of the door actuator? When I use the FOB it will not lock the door but it will arm the alarm.


I have already replaced the Bose Amp due to moisture,


Could it be a BCM which is located beside the AMP.


Before I go and spend beaucoup dollars on diagnostics does any have any advise or know what else I can check


Regards.


RDL
 

· Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Update:

I poured water down the sunroof drain tubes and drains the well. I have removed the headliner right to the back to check all drain connections. I removed the rubber elbow on the drain tubes through the firewall. Both were clear. I doused the car with water around the sunroof, moon-roof and windshield, and aside from a couple of drips around the sunroof no evident problems with leaking.

I checked the HVAC drain tube where it goees through the floor board and where it connects to the evaporator casing, and it was clear. I removed the blower motor and it was dry.

Here s where it get weird. I peeled back the carpet on both sides and while the top of the carpet is dry underneath is completely soaked the foam saturated to the point where extracted about 1 Gallon of water and it is still wet. There is also a black rubber (foam backed) mat coming down from the firewall and the foam is also completely soaked.

I am actually surprised that the vehicle has not caught fire through shorting out with all the wires running through the floor.

I honestly do not know where the water is coming from and I do not want to spend thousands of dollars letting GM trying to find out.

I am also more convinced that there is no power going to the door because of either bad connections or corroded wires. Is there schematics available on line for the enclave?

Any help would be much appreciated

Thanks.

RDL
 

· Registered
Joined
·
6 Posts
Have you replaced ANY light bulb on the vehicle? If so, did you get an exact same number bulb as the one that went bad? I do not mean looking in the catalogs that are available at Auto Zone, etc., or have a store employee look it up on their computer, I mean getting the same number bulb that you took off and you see the bulb number in your hands.

Cannot explain this at all (I have tried, as slightly different impedance from bulb to bulb when direct replacements are allowed, etc.) but have had it happen to me and one other friend of mine, not Enclaves, but when my friend asked me why his door locks did not work and a few other things are acting screwy I asked if he had replaced any bulbs in the vehicle recently and the answer was yes, a rear stop light bulb. He still had the old bulb and when next seeing him he asked me what numbers should he play in the next Powerball. True story .
 

· Registered
Joined
·
7,125 Posts
there is a seam- near the area of the struts mount by the wipers-- where water can seep in.
there was a bulleting to apply sealer to the area.
a while back I posted pics on the forums (trav/acadia/enclave)
 

· Registered
Joined
·
1 Posts
My First Post!!!


I own a 2008 CXL. Currently the drivers door locks, mirrors, windows, memory seat do not work. I have already replaced the master switch. (Not the problem as they still do not work). Checked the main harness connection at the door for signs of moisture (Dry). When I open the door the lights do not come on, similarly when I shut the vehicle off and open the door the radio and lights should go out (they do not).


I do know that we have moisture water problems, however maintenance records show that the drain tube extension for the moon roof were already fixed previously. I did have the windshield replaced and contacted the company and had them check it out.


I have checked all the fuses. (Unless there are relays as well I have not checked them) Windows on all other doors work. Door lock button on passengers side door does not work as well. Could this be an addition issue of the door actuator? When I use the FOB it will not lock the door but it will arm the alarm.


I have already replaced the Bose Amp due to moisture,


Could it be a BCM which is located beside the AMP.


Before I go and spend beaucoup dollars on diagnostics does any have any advise or know what else I can check


Regards.


RDL
My First Post!!!


I own a 2008 CXL. Currently the drivers door locks, mirrors, windows, memory seat do not work. I have already replaced the master switch. (Not the problem as they still do not work). Checked the main harness connection at the door for signs of moisture (Dry). When I open the door the lights do not come on, similarly when I shut the vehicle off and open the door the radio and lights should go out (they do not).


I do know that we have moisture water problems, however maintenance records show that the drain tube extension for the moon roof were already fixed previously. I did have the windshield replaced and contacted the company and had them check it out.


I have checked all the fuses. (Unless there are relays as well I have not checked them) Windows on all other doors work. Door lock button on passengers side door does not work as well. Could this be an addition issue of the door actuator? When I use the FOB it will not lock the door but it will arm the alarm.


I have already replaced the Bose Amp due to moisture,


Could it be a BCM which is located beside the AMP.


Before I go and spend beaucoup dollars on diagnostics does any have any advise or know what else I can check


Regards.


RDL
Did you ever figure out the issue? I’m having the exact issue now as well as the drivers heated seat doesn’t work. I have a 2013
 
1 - 6 of 6 Posts
Top