EnclaveForum.net: Buick Enclave Online Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I bought a used instrument cluster from a 2008 enclave. My bottom three gauges burnt out on my 2008. Plugged everything in and it shows the correct mileage of my vehicle, but now I have two issues. First issue is I can no longer reset my oil life. Second issue is I no longer get the option to reprogram any new remotes. Anyone have any ideas of what’s wrong?
 

·
Registered
Joined
·
9 Posts
No clue, but hopefully someone with some knowledge on this will chime in. I’ve got a dim display and am looking at options for repairing or replacing. Did the used one just plug right up and work other than the issues you mentioned?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes it did. I may have figured it out. I may need to buy an obd2 device that will read my old clusters info which I can then copy and write onto the replacement cluster and giving me back full functionality. There is one that gm techs use but it’s $400-$500. Ive found a knock off that’s $100 that seems to have a lot of good reviews so I’ll try that out eventually.

Helpful tip. If you buy a used cluster make sure you turn the ignition key to off before you unplug the old and plug in the new. For some reason if the key is set to acc you have bare minimum functionality such as:
Mileage
Trip A
Fuel Economy

Doing it with acc off you will get all the functionality EXCEPT:
Oil life remaining
Can’t set compass zone
Option to reprogram car alarm keys missing

Your actual odometer mileage will display properly as I believe that info is stored somewhere else other than the cluster. Hope this helps.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
jgalecio
EnclaveForum.net: Buick Enclave Online Community
We’re a forum community dedicated to Buick Enclave SUV owners & enthusiasts. Come join the discussion about upgrades, towing capacity, reliability, and more!
Full Forum Listing
Top