EnclaveForum.net: Buick Enclave Online Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Saturday I pulled my Weather Tech mats out to clean them and found the underside of them all wet. I got the shop vac out and sucked up the water from the carpet. I put some pressure and I could hear the disgusting sound of more water under the carpet in the padding. I pulled the trim piece to look under the carpet and it was saturated and I had water sitting. I started to pull the seats out to get the front carpet out only to find that the back carpet was also saturated. I now have all of the carpet pulled and drying out. I pulled the cowl covering and looked inside with a flashlight, nothing. I pulled the cabin filter, nothing. I lifted up the thick padded rubber that comes from the firewall and that is all saturated. Friday we had some very hard rain and my wife had the Enclave parked outside at work. From removing the carpet I see that the mount that holds the center console is rusty. So evidently this has been going on for a while. I do not have a sunroof. Any ideas? I bought the vehicle used a year ago. I can't tell if it has a new windshield or if it is the factory one. Before I start pumping the exterior with water, I was wondering if anyone else has/had this issue. Any help would be great.
 

·
Registered
Joined
·
251 Posts
Wow, do you know the history of this vehicle, maybe previous owner can shed some light on it. Maybe a windshield replacement company could tell if it has been replaced.

Surprised you haven't had any electrical issues.....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
No electrical issues yet. From what I looked at, no bare wires and the looms are still intact and dry. The vehicle is air drying, thank goodness it is nice and hot in Iowa this week. The windshield is where I am leaning towards right now. We bought the vehicle out of state from a dealer. when I brought it home, I tore into the interior to deep clean it and there was no indication of any water issues, I'm thinking that it just started within the last year.
 

·
Registered
Joined
·
235 Posts
Have you been using the AC?
When you park after using the AC is there a puddle of water under the car in the middle in front of where the shifter is?
I had a similar problem and the drain was plugged underneath. I jacked up the E and put axle stands under it and was able to clean out the drain with a small screwdriver. I got a bit wet as well.
Hope this helps,
Rick
 

·
Registered
Joined
·
5,954 Posts
Does your Enclave have a sunroof? It could be leaking from the drain tubes.
 

·
Registered
Joined
·
733 Posts
Original post said he didn't have a sunroof
 

·
Registered
Joined
·
5,954 Posts
rexster said:
Original post said he didn't have a sunroof.
:confused: thanks rexster
 

·
Super Moderator
Joined
·
21,166 Posts
This is not good! :mad: Let us know the results of your water intrusion test. Good luck.
 

·
Registered
Joined
·
2 Posts
Saturday I pulled my Weather Tech mats out to clean them and found the underside of them all wet. I got the shop vac out and sucked up the water from the carpet. I put some pressure and I could hear the disgusting sound of more water under the carpet in the padding. I pulled the trim piece to look under the carpet and it was saturated and I had water sitting. I started to pull the seats out to get the front carpet out only to find that the back carpet was also saturated. I now have all of the carpet pulled and drying out. I pulled the cowl covering and looked inside with a flashlight, nothing. I pulled the cabin filter, nothing. I lifted up the thick padded rubber that comes from the firewall and that is all saturated. Friday we had some very hard rain and my wife had the Enclave parked outside at work. From removing the carpet I see that the mount that holds the center console is rusty. So evidently this has been going on for a while. I do not have a sunroof. Any ideas? I bought the vehicle used a year ago. I can't tell if it has a new windshield or if it is the factory one. Before I start pumping the exterior with water, I was wondering if anyone else has/had this issue. Any help would be great.

I am having the same problem with mine... have you found a solution I have not?
 
1 - 9 of 9 Posts
Top