EnclaveForum.net: Buick Enclave Online Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have had an oil leak for several months now. I've taken my vehicle into two different dealerships to be serviced for this issue. Both have made repairs but the leak continues from the same area. Has anyone had the same experience?
I have also noticed my car has trouble accelerating and switching gears when I reach about 55 mph. I usually have to let off the gas then it eventually goes. Again, they did all the diagnoses but found no issues.
Thanks
 

·
Registered
Joined
·
6,623 Posts
can you describe the location better....
middle below pass floor-... that mean by the 2nd row?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yes middle of second row. I marked the vicinity with red chalk in hopes it doesn't wash off from the snow this week!
6372
 

·
Registered
Joined
·
6,623 Posts
I dont have an awd.
But I believe that part is called the Torque Tube.
Probably leaking from in there.
You may want to post this on the Acadia forum- more traffic there... and I know theres been folks who have replaced that tube. It probably has some gear lube in it.
 

·
Registered
Joined
·
3 Posts
I have had an oil leak for several months now. I've taken my vehicle into two different dealerships to be serviced for this issue. Both have made repairs but the leak continues from the same area. Has anyone had the same experience?
I have also noticed my car has trouble accelerating and switching gears when I reach about 55 mph. I usually have to let off the gas then it eventually goes. Again, they did all the diagnoses but found no issues.
Thanks
Sorry to hear, had same issue with my Buick from day 1!!!! I got a lemon! I even got papers from a lawyer regarding Buick 2008 guess had lost if issues and recalls! Never again will I buy a Buick!
 

·
Registered
Joined
·
1 Posts
I dont have an awd.
But I believe that part is called the Torque Tube.
Probably leaking from in there.
You may want to post this on the Acadia forum- more traffic there... and I know theres been folks who have replaced that tube. It probably has some gear lube in it.


That's the rear driveshaft. If it's there it's an awd
 

·
Registered
Joined
·
34 Posts
What exactly did each of the two dealerships do in an attempt to repair the leak? And, is it an engine oil, differential oil, trans oil, or some other oil leak? Or power steering fluid leak?
 

·
Registered
Joined
·
195 Posts
Just curious if the condition would continue if you drive with the traction control off.... If the leaks are indeed from the driveshaft/torque tube, then it may very well throw off readings feeding into the Stabilitrak system, causing the control systems to not behave like it was programmed to behave. Hope this helps a little...
 
1 - 9 of 9 Posts
Top