EnclaveForum.net: Buick Enclave Online Community banner

1 - 20 of 40 Posts

·
Registered
Joined
·
743 Posts
Discussion Starter #1
Does anyone know of problems with Oxygen Sensors on the Enclave ? One of our members have had problems with Oxygen Sensors and I thought it had been resolved. My Dealer told me today that the Vehicle had been back about 4 times with the same problem. It might be just an isolated case, but I thought I would mention it. The owner will probably give details later.
 

·
Registered
Joined
·
1,417 Posts
rocketman said:
Does anyone know of problems with Oxygen Sensors on the Enclave ? One of our members have had problems with Oxygen Sensors and I thought it had been resolved. My Dealer told me today that the Vehicle had been back about 4 times with the same problem. It might be just an isolated case, but I thought I would mention it. The owner will probably give details later.
???
 

·
Registered
Joined
·
743 Posts
Discussion Starter #3
Yes MsS42, you read it right. I happen to know the owner from the same Dealership as mine, and the info was given to me today. I thought I would mention it so if anyone else heard of a problem, we could get it out in the open and discuss.
 

·
Registered
Joined
·
1,417 Posts
ROCKETMAN,

THE ??? WAS CAUSE I WANTED TO KNOW WHAT THE HECK IS A OXYGEN SENSOR :p
 

·
Registered
Joined
·
743 Posts
Discussion Starter #5
I'm not an Auto Mechanic, but I believe it would have to do with Air/Fuel mixture or efficiency. There's probably 2 or 3 on the Vehicle. Someone else in this group can probably enlighten us a little.
 

·
Registered
Joined
·
1,417 Posts
thought u knew what it was since you brought it up.. i will ask my dad . after 4 times returning for same problem...time for an exchange.
 

·
Registered
Joined
·
743 Posts
Discussion Starter #7
Lot of people bring up situations that they don't know or are unfamiliar with, but they still put it out there so that it can be discussed and everyone can learn from it.
My objective was to see if there are other problems pertaining to Oxygen Sensors. OK ?
 

·
Registered
Joined
·
1,417 Posts
rocketman said:
Lot of people bring up situations that they don't know or are unfamiliar with, but they still put it out there so that it can be discussed and everyone can learn from it.
My objective was to see if there are other problems pertaining to Oxygen Sensors. OK ?
no rocketman, dont take offense please.... i was just merely saying i asked you what it was cause i thought you knew... sry if i offended you. :'( i will find what it is and then i will post so we will both know.
 

·
Registered
Joined
·
743 Posts
Discussion Starter #9
That's what this Forum is supposed to be about !!!!
 

·
Registered
Joined
·
5 Posts
oxygen sensors are in the exhaust system, and measure the ammount of air/oxygen in the exhaust, which lets the engine computer adjust the air/fuel mix to lessen emissions, and help mileage (better a/f ratios help gas mileage/efficiency)
 

·
Registered
Joined
·
1,417 Posts
thanks for that bit of good info... i hadn't had a chance to talk to my dad so i could ask him. now i dont have too you have cleared it up for us.... :thumb:
 

·
Registered
Joined
·
743 Posts
Discussion Starter #13
Thanks Toasty !!! :)
 

·
Registered
Joined
·
172 Posts
I just checked GM Electronic Service Bulletin's and there is no mention of any oxygen sensor problems. This is the same information that the dealers get access to and are updated daily. Must be a isolated case.
 

·
Registered
Joined
·
124 Posts
Ticner,

what is on the TSB list?
 

·
Registered
Joined
·
7 Posts
Not an isolated case for oxygen sensor. Mine went off. The dealer replaced the gas cap. I think that was a crock. Probably will go off again. I believe there is some overall problem with the computer. So far, in 5 weeks my Enclave has had the the Stabilitrak light go off three times, (the dealer just clears it, can't find the problem), 2 times for the rear park assist not working (again, the dealer can see it in the history but said just turn the car off and on), the compass on the mirror always pointing west (just turn the car off and on again!!) and the interior lights not turning off after shutting off the car (again, told to just turn the car off and on again). My grand total times in the shop 8!!!!!
 

·
Premium Member
Joined
·
7,065 Posts
eastendgal said:
Not an isolated case for oxygen sensor. Mine went off. The dealer replaced the gas cap. I think that was a crock. Probably will go off again. I believe there is some overall problem with the computer. So far, in 5 weeks my Enclave has had the the Stabilitrak light go off three times, (the dealer just clears it, can't find the problem), 2 times for the rear park assist not working (again, the dealer can see it in the history but said just turn the car off and on), the compass on the mirror always pointing west (just turn the car off and on again!!) and the interior lights not turning off after shutting off the car (again, told to just turn the car off and on again). My grand total times in the shop 8!!!!!
eastendgal
I am sorry to hear about your problems. I have not experienced any on them on my Enclave.
However, I HAD a recurring problem with my 2005 LeSabre, "service stability system" light came on. Each time it was serviced, they replaced a part and it was fine for a few weeks or months. After 4 attempts, the dealer service manager contacted someone at GM technical and suggested replacing the complete module. It has been several months and the problem seems to have gone away. NEVER did this affect the driveability of the vehicle. Our cars have become so complex that sometimes the diagnosis is difficult. All in all, the dealer handled everything in a professional and courteous manner. Each time I received an in house loaner vehicle, usually a LaCrosse.
When I mentioned the repeat issues to my salesman, he was already made aware from the service manager. Being that my warranty expires in 10 months, he offered to try to get GM to supply an extended warranty at no cost to me. I seems that GM(Buick) is striving to keep their customers happy. He said it is likely that everything will fall into place as he proposed, but I do not yet have a confirmation. With the Enclave being my 4th vehicle from this same dealer, I have every confidence that he will take care of me.

Good luck in resolving your problems. It seems that it is time to find a NEW dealer to service your Enclave.
 
R

·
Guest
Joined
·
0 Posts
Smokin SRX said:
MRBUICK is right! Get a new dealer...not a new car. His service committment seems to be at "Flinstone" level! ;)

LOL, when ever i see the flinstones i think of this joke


i may not be fred flintstone but i can make your bed ROCK.
 

·
Registered
Joined
·
24 Posts
My check engine service light went on last week for two days. When I took the 2009 Enclave to the dealership, the light was already off but the computer does indicate oxygen sensor problem. The mechanic just reset the computer and told me that if the check engine light goes on, the oxygen sensor will need to be replaced. They quoted me approximately $400 for labour and part. It seems quite high. Has anyone tried to replace the oxygen sensor themselves?
 
1 - 20 of 40 Posts
Top