EnclaveForum.net: Buick Enclave Online Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Allo,

2010 Buick Enclave CXL.
The car just put up all these codes today.
P069E, U0073, U0100, P0430, P3335, P3600, U0109

Some of them a couple days ago

P069E indicates the FPCM has detected a problem with the fuel system
U0073 Control Module Communication Bus 'A' Off
U0100 Lost Communication With ECM/PCM
P0430 Catalyst System Efficiency Below Threshold (Bank 2)
P3335 O2 sensor related????
P3600 O2 sensor related????
U0109 Lost Communication with Fuel Pump Control Module (FPCM)

Any ideas where to start with this?
When this pops up, instrument cluster stops working, traction control off.
Not sure if its a short or some other issue. FCPM possibly.

One question I have is, can a Control mode just be swapped without issue?

Any help appreciated.

thanks.
 

·
Registered
2015 Enclave Leather.
Joined
·
658 Posts
With more than one communication module errors, I would lean toward a pinched wire on the communication wiring OR the Main Fuse Block under the hood isn't providing power properly, check for loose connections underneath the fuses. Any work done recently?
 

·
Super Moderator
Joined
·
531 Posts
How old is the battery? I’d pull the terminals and clean them good making sure they were good and tight putting them back.

When ever that many codes pop up out of of the blue the first thing I think about is a low battery, bad battery connection or a bad ground. Voltage issues will cause all the sensors to start showing up out of range.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
The battery was replaced 12/26/2017 at 118,500 miles, car is now at 138,500. I checked voltage on the battery and it was 12V. seems ok. Terminals seemed ok also.

Mind you i had the engine replaced last year. it's been so-so since. Had a year warranty on it... its now passed a year.


I've had these odd times where the car won't star and throw some codes. Good chance there is a short.
For example the radio will switch band on its own.... tap it and it comes back,..... guessing something wrong in the head unit.
Very finicky car.
I would sell it if I could...
 

·
Registered
2015 Enclave Leather.
Joined
·
658 Posts
Well since there was major work done under the hood, I would suspect that something wasn't connected back properly, possibly a ground.
 
1 - 6 of 6 Posts
Top