EnclaveForum.net: Buick Enclave Online Community banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2010 Enclave CXL with 115000 miles and my CEL came on 25 days before my Cali registration is due with a mandatory Star Smog check.

The code was P2099 which i believed to be bank 2 downstream O2 sensor, so i swapped the bank 1 and 2 O2 sensors to confirm this diagnosis, cleared the code and started the 200 mile drive cycle. Im 180 miles into that cycle and the permanent evap code cleared but i now have a pending P0496 purge valve.

Are these unrelated and coincidental or is something else going on? Im down to 15 days to fix this before Smog/registration should i just replace the O2 sensors and the purge valve and cross my fingers?

thank you in advance.
 

·
Registered
Joined
·
4 Posts
I have a 2010 Enclave CXL with 115000 miles and my CEL came on 25 days before my Cali registration is due with a mandatory Star Smog check.

The code was P2099 which i believed to be bank 2 downstream O2 sensor, so i swapped the bank 1 and 2 O2 sensors to confirm this diagnosis, cleared the code and started the 200 mile drive cycle. Im 180 miles into that cycle and the permanent evap code cleared but i now have a pending P0496 purge valve.

Are these unrelated and coincidental or is something else going on? Im down to 15 days to fix this before Smog/registration should i just replace the O2 sensors and the purge valve and cross my fingers?

thank you in advance.
Wow! Same thing happened with my BMW X5. Anyway, we have a 2013 Buick Enclave, and the purge valve threw the same P0496 code 6 months ago. Cost me $25 and 5 min to replace. Problem solved! Hope the P2099 code doesn’t come back on. Good luck!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top