EnclaveForum.net: Buick Enclave Online Community banner
1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I tried registering on the Buick Owners Link (GMLINK). It d/n recognize my VIN# (It's been 60 days since purchase) and did not even have the Encalve as a selection choice! Anyone else having problems?
 

·
Registered
Joined
·
360 Posts
Everybody I believe. Thw real question is has anybody been successful?? If so, how?? ???
 

·
Registered
Joined
·
181 Posts
I can't even get into it! It gives me an error message when I try to enter a vehicle. I had a Rendevous on it and deleted it when I gave the car to my Son.
 

·
Premium Member
Joined
·
1,997 Posts
What is the website? I'll try now.
 

·
Registered
Joined
·
249 Posts
mygmlink.com

I tried but my VIN wasn't also recognized. It did say the VIN won't be in the database if you purchased the vehicles less than 60 days. And if you try the other method of putting in the Make and Model, the Enclave is not even listed. This tells me that this site is not as active as it should be. It's not GM's priority because not too many people are complaining enough.
 

·
Premium Member
Joined
·
1,997 Posts
OK, It recognized my VIN, asked for current mileage, avg miles driven per day/month, and then vehicle nickname. It then confirms the VIN and asks for Make/Model/Year. Enclave isn't an option so that's as far as I got.
 

·
Registered
Joined
·
525 Posts
I've had my Enclave for 6 weeks and mygmlink says my vin is a good vin number but not in the system yet and to try after 60 days of ownership. The OnStar site, on the other hand, has been sending me email links to my vehicle status from the get go. I guess OnStar being a paid service might have something to do with it.
 

·
Registered
Joined
·
3,130 Posts
mygmlink sucks. We have had our Enclave since April 30th and still can not register the vehicle.
 

·
Registered
Joined
·
49 Posts
I have tried the last 4 weeks; 60 days since buying our Enclave. I am going to notify the dealer.
 
1 - 9 of 9 Posts
Top