EnclaveForum.net: Buick Enclave Online Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have been trying to solve a shudder or jerking motion when climbing a hill or accelerating at low rpms. I have changed the transmission fluid, added lubegard, changed the coils and spark plugs, and changed the front engine and transmission mount. The engine runs much smoother and shifts are good. However there is still a shudder or jerking motion when the rpms are low enough like when climbing a hill. Downshifting solves it, but the problem is concerning. The timing chain was replaced 10,000 miles ago, the car has 195k miles on it. I also have an occasional p420 and p430 for cat efficiency, but I've replaced the sensor and catalytic converters without luck.

Could it be an injector or Torque converter?
 

·
Registered
Joined
·
305 Posts
What year?

I have a memory that my wife's 2008 did that; kind of felt like it was selecting two gears at once and would not do it under hard acceleration or if we manually shifted it and held the gear longer than it would automatically. In our case, it was the computer inside the transmission which can be changed "relatively" inexpensively (you can even do it yourself ... search "Techem Enclave transmission" or something like that, and watch the YouTube videos.

In our case that was all that was actually wrong, even though I had it totally rebuilt at about 140,000 miles because I was afraid of the wave plate issue. Turns out my wave plate was still perfect. Go figure. Trans place owner said he was not surprised ... he sees more problems with the computers than the wave plates, which I found interesting.

There is a trick to fixing the P0420 and P0430 codes, if you don't mind doing something slightly shady.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
It's a 2011. Do you mean you replaced the TEHM? I did replace the "seals" in the TEHM when I installed the transgo shift improvement kit.
 

·
Registered
Joined
·
305 Posts
Sorry I never noticed your question until now, and you probably won't see this, but yes, we did an entire rebuild including the TECHM. Turned out the TECHM was all that was wrong, so it may be different than what you were experiencing.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
rwagoner
EnclaveForum.net: Buick Enclave Online Community
We’re a forum community dedicated to Buick Enclave SUV owners & enthusiasts. Come join the discussion about upgrades, towing capacity, reliability, and more!
Full Forum Listing
Top